Debian 7.0 and Ubuntu 13.04

May 8, 2013 12:59 pm

We’re pleased to announce the availability of Debian 7.0 (release notes) and Ubuntu 13.04 (release notes) for deployment within the Linode Manager in both 32 and 64 bit flavors. You can read our documentation in the Linode Library if you are unsure of how to deploy a Linux distribution in the Linode Manager.

Debian 7.0 (Wheezy) will be supported one year after the next major Debian release. The Debian project currently operates on a two-year release cycle, so the estimated EOL date is sometime in 2016. The 13.04 release of Ubuntu (Raring Ringtail) will be supported by Canonical until January of 2014. If you require a release of Ubuntu with a longer support life you can deploy Ubuntu 12.04 LTS which has support until April of 2017.

In addition to these new distribution offerings, we’ve updated our Debian 6 and Ubuntu 12.04 LTS images. The Debian 6 image includes updated system packages and the removal of nfs-common and portmap. The Ubuntu 12.04 LTS image has been updated to Ubuntu 12.04.2 which includes a fix for the bug mentioned in our availability announcement in addition to the removal of the whoopsie package.

Cheers!

-Tim

19 Responses

  1. Thanks for the good work guys 🙂 Looking forward to this.

  2. Thanks for the news. Is there an easy way to update currently used Ubuntu LTS 12.04 to match your update image? Would apt-get update take care of this? Or do I have to reinstall it using your image?

  3. Yup, the following will get you from 12.04 to 12.04.2…
    sudo apt-get update
    sudo apt-get remove whoopsie
    sudo apt-get upgrade

  4. An LTS release of Ubuntu will only update to another LTS release. So if you’re on 12.04 LTS, it won’t auto-update to 13.04. You’ll need to wait for 14.04 LTS.

  5. @Mohamed^^

    apt-get update and apt-get upgrade should be enough 🙂

  6. The same question, but for Debian: is there a way to upgrade a debian6-x64 based node without creating a new system disk?

  7. @Raffaele: you can change ‘squeeze’ to ‘wheezy’ in /etc/apt/sources.list and then run apt-get update && apt-get dist-upgrade.

  8. I don’t see the point why apt-get dist-upgrade with Debian is impossible per se.

  9. Thanks guys, our fleet will rock Debian 7.0 pretty soon!

  10. Raffaele: You can simply follow the upgrade procedures from the documentation.

  11. Very nice, I will create a new instance of wheezy
    : D

  12. …and what about ext4? If I’m not mistaken, this is the new default file system for debian7, isn’t it?
    Are you planning the support for ext4 too?

  13. Thanks for the upgrade. Now I am using Ubuntu 13.04. 🙂

  14. I have successfully upgraded my box to Wheezy from Squeeze with “apt-get”. See this Linode document for the reference

    https://library.linode.com/upgrading/upgrade-to-debian-7-wheezy

  15. If you have 3rd party repositories, just be aware when updating that these repo’s might not yet have Ubuntu 13.04 packages.
    So double check.

  16. @geoff “do-release-upgrade -d” will upgrade an LTS to the next non-LTS release.

  17. @Feng: it’s not impossible per se. It’s just that Linode’s default sources.list file explicitly names the version (“squeeze”) rather than using “stable”. That effectively pins the system to that version of Debian rather than having it float to the current stable version. If you use “stable” in sources.list instead of “squeeze” or “wheezy”, dist-upgrade will automatically upgrade when the stable release changes.

    Downside: if you happen to have out-of-date packages when the version switch occurs, things can go wonky in a hurry. You won’t know exactly when the switch will happen, so it’s easy to get caught by it. That’s probably why the Linode default is “you won’t get it until you ask for it”.

  18. Nice and thanks for the upgrade.

  19. This is a great news!
    @Feng: thanks for the link, it’s very helpful.

Leave a Reply