Bug Fix – Network Drops and Connectivity Blips

January 19, 2004 2:26 pm

I released a change in the host-side network configuration for the Linode’s network setup that fixes a number of related, long-outstanding and not easily reproducible bugs:

[list][*]Random disconnects when others rebooted on the same host.
[*]Complete loss of connectivity if the MAC address timed out in the bridging table. (requiring the log-into console and ping the host work-around)
[*]A potentially measurable improvement in network performance, since each packet now avoids a change I made to the bridging code in the host kernel.[/list]You’ll get the fix next time you reboot. No changes are required on your end.

This bug had the second highest priority/nag level on my bug list for the past many (6) months, so I am very pleased to finally eliminate it :). It was the only network related bug, so the network is completely solid now.

Thanks!
-Chris

3 Responses

  1. Is it the reason why clients were getting mail bounces some times? or users have to refresh the site in browser twice or thrice if someone visits after long time? I am host 12.

  2. [quote:90dc249f69=”strike”]Is it the reason why clients were getting mail bounces some times? or users have to refresh the site in browser twice or thrice if someone visits after long time? I am host 12.[/quote]

    From IRC: “no such mailbox on this server”

    This doesn’t sound like a network related problem.

    -Chris

  3. Nice one Chris (Caker) 🙂

    Regards,
    Garry

Leave a Reply